No announcement yet.

Trouble ignoring columns

  • Time
  • Show
Clear All
new posts

  • Trouble ignoring columns

    Either I'm having a hard time figuring out how the column ignore function works, or they don't work with text files...

    I'm trying to ignore text after a specific column, so I created a grammar rule that specifies to only consider the first x columns.
    But, even though the beginning of the lines are identical, I *still* get the differences highlighted in red (see screenshot ignore1.gif). And if I select to "Ignore unimportant differences" these lines will still be there.

    I am also not quite sure if these rules define the *important* or *unimportant* differences. The manual refers to a "'New' button in the Unimportant Text area", but I don't see any area that is labeled as such, so it might be that the manual is a bit out of date.
    So, I tried it the other way round as well: Instead of defining column 1 to 3, I specified column 4 to <end of line>, but in either case all lines were highlighted (see screenshot ignore2.gif).

    (I am running V3.3.4, build 14431)

  • #2

    It looks like you almost have it. Once defined, you need to setup the Importance tab of the Session Settings. Checked items are Important, and Unchecked items are unimportant.

    In your first screenshot, you correctly have the grammar defined as 1 to 3 and checked, but you didn't uncheck "Everything Else" to mark things that aren't a grammar as unimportant. In the second screenshot, you switch to "4" to end of line, but didn't uncheck the grammar name to define that grammar as unimportant.

    Here's a KB article that might help (it also includes a video) that is a step by step guide:
    You are nearly at the end of the guide, and just need to define the Unimportance (then propagate that settings to the default session settings, or to a folder compare).

    Please let us know if you have any questions.
    Aaron P Scooter Software


    • #3
      Hmm... thanks for the clarification (and I've been able to activate it properly now), but, and I hate to say that, since I normally like BC quite a bit—but that rules interface is a mess...

      It doesn't match what the manual says, it gives no indication that you're toggling something from important to unimportant, the "Everything else" option would lead me to believe that it only affects case checks (as that's the only thing that indented underneath), and it seems I'm unable to turn a rule off altogether (i.e. I can only switch it from important to unimportant—which is not really enough if I want to keep a few rules for specific comparisons).

      Hopefully that section is still work-in-progress?


      • #4
        Reworking the interface for rules/file formats is definitely something on our radar, but the current set of settings should be completely functional. If you are familiar with BC2, everything could be globally defined as either "Unimportant" or a "String" (Important) in a Rule. Anything that didn't match these was considered 'everything else' but was never explicitly stated what that meant; in BC2 it means it is Important.

        In BC3, grammar items are defined generically, and you can then set them to be Important (like String) or Unimportant. "Everything Else" is not toggle-able as Important or Unimportant. The Case options simply refer to how to handle case for Everything Else text, since there is no "everything else" grammar item to add that option (the other grammar items have case handling within them). The phrases and checkboxes are within a section labeled "default text", but this could be made a bit clearer.
        Aaron P Scooter Software


        • #5
          Also, the manual you reference is for BC2.

          For BC3, we have some videos, here:

          and the Unimportance KB mentioned above, here:

          Aaron P Scooter Software


          • #6
            Having troubles too...


            I also can't get exclude a part of the line being compared.
            I am comparing Visual Basic files (*.frm), and I want to ignore the VB line numbering.
            But whatever I try, the numbers keep being shown.

            Starting in the file tab window, I select the Rule button and then I have defined the rule (Regelnummers).
            But the line numbers keep showing up in red.

            What am I doing wrong?
            Best regards


            • #7
              Are the line numbers the first 5 characters? It looks like you've defined the grammar to match on characters 5 to the end of the line. If you want to match on the first 5, use 1 to 5, or a RegEx like:

              Once the grammar is defined to match on the first 5 characters or line number, then when unchecked that section of text will be unimportant.

              If you are still having any trouble, please email [email protected] with
              - A pair of sample files
              - A from the Help menu -> Support; Export
              - A link back to this forum thread for our reference (so we can look at this screenshot)
              Aaron P Scooter Software


              • #8
                I was sure I tried that first, selecting Columns; Starting at column 1, ending at column 5 and then deselect the rule.

                But I must have made a mistake, now (with this rule on top) it's working.
                Thanks for your advise!


                • #9
                  Hello Paul,

                  The key to remember is that you define a grammar, then decide the Importance. So you could have a grammar for 1-5, and mark it as Unimportant. Or you could have a grammar for 6 to end, mark it as Important, then mark Everything Else as Unimportant. There are multiple degrees of control.
                  Aaron P Scooter Software