Announcement

Collapse
No announcement yet.

csv file: qualified text not recognized as such

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • csv file: qualified text not recognized as such

    Hello,
    I'm comparing 2 *.csv files.
    This is a sample:
    ...
    "0001","PARAMETER","0001",2,"A","1","VERMEIRENL",N ULL,""
    "0001 EN","PARAMETER_LABEL","0001","EN","LANGUAGE CODE"
    ...
    I use the standard settings for *.csv format: delimiter(comma) and text qualifier (quote).
    As you can see, the 3rd colum is quoted, so i.m.o. it should show in the interface as 0001, but it appears as 1 (leading zeroes are dropped).
    I don't have this problem with the first column, presumably because in the next records it isn't always completely numeric.
    I'm using version 3.3.3, build 14128.

    Regards,
    Luc Vermeiren

    Belgium

  • #2
    Hello,

    CSV files often have "quotes" around each cell as a means to contain a line break, a double-quote, commas, or simply for readability/standardization, and not necessarily to define as Text/String every time. Our auto-detection will read the entire column and then try to determine if it is text or numeric (or date or a Boolean), but this can be overridden by right clicking the column header and switching it to Text. This can also be done in the Session Settings dialog, and can be set as a global session default for any particular column.

    The defaults can be set within the session by updating the Session Setting dialog dropdown from "Use for this View" to "Also update session defaults" or from the Home screen, in the Saved Sessions list, in the Edit session defaults folder, select the Data Compare and alter the settings here.

    Update: Also, all BC 3.x updates are free for 3.x users and contain a variety of bug fixes and new enhancements. You can update from the Help menu -> Check for Updates or directly from our download page if you would like.
    http://www.scootersoftware.com/download.php
    Last edited by Aaron; 08-Oct-2012, 11:27 AM. Reason: Update
    Aaron P Scooter Software

    Comment


    • #3
      Thanks,
      quick reply much appreciated.
      I changed the session default to treat _all_ columns as text, and it seems to work well.

      Comment

      Working...
      X