Announcement

Collapse
No announcement yet.

Simple comparison not working properly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Simple comparison not working properly

    I'm running the 3.3.5 trial version and I've tried to compare almost same text but it's not able to highlight the difference ( of simple 1 line : /* df */).

    Did I miss any settings?

    I've attached the comparison.
    Last edited by rag_gupta; 28-Feb-2013, 10:54 PM.

  • #2
    Hello,

    Our character by character alignment does not always find the optimal match, as it attempts to match similar bits of text. If you enable the View menu -> Alignment Details, you should see the details, character by character, in the bottom status bar. Does this show equal characters aligning (just not the ones you expect)?

    If you are still having any trouble, please feel free to post or email us at [email protected] with a full screen screenshot and a pair of sample files. We should be able to work with those to reproduce the behavior you are seeing.
    Aaron P Scooter Software

    Comment


    • #3
      Here are those two files. Can you please compare them using text compare?

      Thanks

      Comment


      • #4
        Hello,

        If you go to the Session menu -> Session Settings, Alignment. Are you using a Standard method, with 2000 Skew tolerance and "Use closeness matching" enabled?
        Aaron P Scooter Software

        Comment


        • #5
          Yes those default settings are enabled and I've not touched them at all.

          Comment


          • #6
            Hello,

            Thanks. We'll need you to email us at [email protected] with your current BCSupport.zip (generated from the Help menu -> Support; Export). With this, we should be able to reproduce the problem you are seeing with these files.

            Please also include a link to this forum thread in the email, for our reference so we can re-read and grab a1.txt and a2.txt again.
            Aaron P Scooter Software

            Comment


            • #7
              Same issue has occurred again. The settings are as confirmed by you above and I've tried to compare after restarting BC.

              I've added only 3 line comment and it is not able to make it out.

              I've heard good reviews about BC ... but I've deferred purchasing it because of this issue.

              Comment


              • #8
                Hello,

                I'm having trouble finding your previous email in our archive. Would it be possible to get a fresh set of current files and your BCSupport.zip?

                Please email us at [email protected] with:
                - updated a1.txt and a2.txt (with the 3 new comment lines)
                - A new BCSupport.zip from the Help menu -> Support; Export
                - A full screen screenshot showing the problem section
                - A link back to this forum thread (which, is what I am attempt to search our archive on now, but not getting any hits).
                Aaron P Scooter Software

                Comment


                • #9
                  Hi,

                  I checked the a1.txt and a2.txt files with standard settings and the added /* df */-comment is shown as orphan on right.
                  If I set Alignment to Unaligned I get the same as the screenshot from initial post, but thats no surprise for me.

                  Greetings Lutz

                  Comment

                  Working...
                  X