Announcement

Collapse
No announcement yet.

How To Ignore White Space in BC v3.3.5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How To Ignore White Space in BC v3.3.5

    I have both Beyond Compare v2.5.2 (BC2) and v3.3.5 (BC3) installed on Windows XP SP3, fully updated.

    When I compare two text files using BC2, I can click on the "Minor" icon so that it is highlighted. Then the lines that are different only because of white space disappear from the "Diffs" view.

    When I click on "Rules" and "Importance", all the boxes in "Unimportant text" are checked because I want all white space ignored. This is exactly how I want and expect BC to work.


    But, in BC3 this does not happen. In fact, the reason I have kept BC2 installed is because I have never been able to do this simple comparison and get the white space ignored. So I use the old version for this task.

    But, at long last, I thought it was time to get to the bottom of this problem, and hence my new thread.

    So in BC3, I compare the same two files that worked fine using BC2. If I click on "Minor", the "Diffs" view does not change. In fact, none of the views changes - "All", "Diffs" and "Same".

    When I click on "Rules" and "Importance", only "Everything else" is checked.

    If I uncheck "Everything else", then not only the characters that are different are shown in blue, but also the characters that are the same but out of position because of extra white space. So lines that have the same characters plus some extra white space are indicated as different. This is not what happens in BC2 and not the way I would expect BC3 to work.

    Maybe I have changed some other setting to cause this to happen, but I haven't found it.

    Finally, could BC2 and BC3 be conflicting? I wouldn't have thought so, but I thought I'd ask.

    I really hope I haven't done something stupid but, if I have, I apologise.

    Please help!

  • #2
    Hello,

    We could provide detailed instructions if you can send in a pair of sample files, along with your BC2 Support.zip (Help menu -> Support; Export) and your BC3Support.zip from the Help menu -> Support; Export. Please email these to [email protected]

    Generally, BC3 has more grammar elements defined by default. If the whitespace is inside of a grammar element, then it's importance is controlled by that element's defined importance. Given your description, I would make a New Text format (in the Tools menu -> File Formats), and move it to the top of the list and assign the file mask to match on your files. The topmost file mask is the one used automatically when opening files.

    In the Grammar tab, make sure no elements are defined. That way, everything is "Everything Else" text (which is checked), and all whitespace is then unimportant (unchecked).
    Aaron P Scooter Software

    Comment

    Working...
    X