No announcement yet.

BC4 doesn't always show all conflicts in file

  • Filter
  • Time
  • Show
Clear All
new posts

  • BC4 doesn't always show all conflicts in file

    Hello all! maybe you can help me with a problem I've had.

    While using BC4 as a mergetool, I've seen instances that when a new file open, I know there are conflicts, if I open the same file in a text editor I can see the conflict tags, but no conflict markers are shown in beyond compare and it seems like it auto-resolved it.

    This looks cool at first, but it's not always a good thing, I've had instances where something that was not meant to be removed was removed by this autoresolution, is there a way to make sure that beyond compare always show the conflict red marks even if beyond compare autoresolved it? or is it a bug?

    I would like to be able to turn this off but I don't know where I can see this.

    I've seen this happening often most of the time when the change is made at the bottom of the file, either by removing or adding info by the end of files.

    Also happens when I moved part of code around.

    Anyone seen this?

  • #2
    It might help to make sure View > Ignore Same Changes and View > Ignore Unimportant Differences are both turned off.

    Selecting an alternate alignment algorithm might also help. In the Text Merge, click the Rules toolbar button (referee icon). In the Alignment tab, change from Standard alignment to Myers O(ND) or Patience Diff. To make it the default for new Text Merge sessions, change the dropdown at the bottom of the dialog from Use for this view only to Also update session defaults before you click OK.

    If you can share example files that demonstrate the problem, please send them and your settings to [email protected] and we'll investigate. To save your settings to a file, open Help > Support, then click the Export button.
    Chris K Scooter Software