No announcement yet.

BC4 and Context Menus Missing

  • Filter
  • Time
  • Show
Clear All
new posts

  • BC4 and Context Menus Missing

    As the title says, I am missing the context menus for BC4 on my main dev machine.

    I think something may have gotten screwed up due to also having BC3 also installed (for transition), because the context items WERE there for it. But, obviously I want the context items to launch BC4, so I uninstalled BC3 ... but the menus are now gone and I cannot get them back.

    * I seem to remember in the past having both context menus at the same time for different versions ... should I have seen this for BC3 and BC4?

    * I have uninstalled and reinstalled BC4 several times and it still does not work. I have checked and unchecked the context menu option setting and still nothing shows.

    * I will say that the first time I uninstalled BC4 I got an access violation at the end, so I am not sure if that messed something up (but it still wasn't working before uninstall anyway)

    * I have googled about this and keep reading about a reg file that will removed cirrus reg entries (which are still left over after uninstall) so maybe that is the issue? I cannot find this reg file though.

  • #2

    We can email the reg file if you email us at sup[email protected] with a link back to this forum thread for reference.

    Which OS are you running, and where is BC4 currently installed? Is it the latest 4.2.2 release? 32bit or 64bit version of BC4 (Help menu -> About dialog)?
    Aaron P Scooter Software


    • #3
      Originally posted by Aaron View Post

      We can email the reg file if you email us at [email protected] with a link back to this forum thread for reference.

      Which OS are you running, and where is BC4 currently installed? Is it the latest 4.2.2 release? 32bit or 64bit version of BC4 (Help menu -> About dialog)?
      Running Windows 10 Pro 64 bit.
      Installed latest release Version 4.2.2 (build 22384)


      • #4
        Sadly, the application of the reg file did not fix it after a restart.


        • #5

          Did you edit the Add.reg file's paths to match your default install location of either Program Files\Beyond Compare 4\, or Program Files (x86)\Beyond Compare 4\, in all locations within the the file?

          If so, you may need to perform a clean uninstall and reinstall. In the email, we also included a Remove.reg.

          First, back up your existing settings with the Tools menu -> Export dialog.
          Then Uninstall BC4, run the (edited if needed) Remove.reg. Then reboot your computer. This should be a clean state.

          Then attempt to install using the newest setup.exe from our website:

          Does this get you up and running? If not, try rebooting, retesting, and then using Add.reg and rebooting. The key is Windows will lock down the shell extension and only allows changes during a restart, so any changes we attempt to apply to it may be queued until a reboot is completed. For troubleshooting purposes, reboot whenever testing between these steps.

          If this doesn't get it up and running, you may have a shell conflict recently installed. Use ShellExView to disable all shell extensions except for the defaults and BC4, then reboot. If this gets BC4 working, then one of the disabled shells is a conflict. Slowly re-enable a batch at a time to find which one is the problem and let us know. That program may need an update.
          Aaron P Scooter Software


          • #6
            I've found the reason of this problem. Checking with RegDllView.exe, you'll find the the register shellext is BCShellEx.dll, not BCShellEx64.dll. After modifying the registry HKEY_CLASSES_ROOT\CLSID\{57FA2D12-D22D-490A-805A-5CB48E84F12A}\InProcServer32 to BCShellEx64.dll, everything is ok.


            • #7

              Was your computer ever running a 32bit OS, later upgraded to a 64bit OS? And was BC(BC3 or BC4) installed while the computer was still a 32bit machine?
              Aaron P Scooter Software


              • #8
                My computer was new-installed windows 10 x64 1607, not upgraded from x86。After few days, it upgraded to 1703 itself. The context error existed both 1607 and 1703.
                Last edited by flintning; 08-Jun-2017, 12:55 AM.


                • #9
                  Thanks for that info. I'll pass this on to a developer and see if we can figure out what caused this flip.
                  Aaron P Scooter Software


                  • #10
                    Hello all,

                    Just to provide a feedback,

                    I had a similar problem. In the past, I´ve installed an old version 3 (trial), and then uninstalled. It worked fine.
                    Other day, I´ve installed the version 4.0.7 (full), and beyond compare stopped to show it in explorer context menu.
                    In meantime, I´ve tried un-install, install, restart, admin...

                    Solution: Using the ShellExView I´ve realized that:
                    Extension Name : CirrusShellEx
                    Missing File : Yes
                    So checking the path, I saw that it is related to the old installation:
                    Filename : C:\Program Files (x86)\Beyond Compare 3\BCShellEx64.dll
                    and then changing to C:\Program Files (x86)\Beyond Compare 4\BCShellEx64.dll via regedit, it works sucessfully.

                    Possibly, the un-install of version 3 and install version 4, it is not updating the regiter CLSID
                    CLSID : {57FA2D12-D22D-490A-805A-5CB48E84F12A}


                    • #11
                      Got similar sounding issue ... fresh install of 64 bit 4.2.3 and no content menu :-(

                      Checked with ShellExView, CirrusShellEx is there, and enabled.

                      I'll email support ... can I also please get a copy of the reg file


                      • #12
                        Received your email and replied with the reg patch. Let us know if that helped get it up and working.
                        Aaron P Scooter Software


                        • #13
                          I had the same problem - missing context menus in Win10 Pro x64 - with the latest installation (BCompare-

                          The solution proposed by flintning worked for me, too:
                          After modifying HKEY_CLASSES_ROOT\CLSID\{57FA2D12-D22D-490A-805A-5CB48E84F12A}\InProcServer32 from BCShellEx.dll to BCShellEx64.dll, everything seems OK.

                          I suppose that's all the reg file mentioned would do, too?

                          Aaron: Since the issue (and its solution) seems to be well known for quite a while already, it is high time you passed this message on to the developer!


                          • #14
                            The reg file is a full removal of all entries manually, and re-adds them, so it's designed to fix any issues that might crop up, not just that one.

                            We have a tracker entry to investigate this, but haven't yet figured out the root cause of how it could end up with the 32bit shell extension entry instead of the 64bit one.
                            Aaron P Scooter Software


                            • #15
                              I need to add one more point to the discussion, I had the missing context menus happen to me recently on Windows 10 (I can't remember if it was after a Beyond Compare update or a Windows Update)... I looked at the registry as was suggested by another post. The problem with mine was that I installed Beyond Compare on my D: drive, not the C: drive... the entry had the proper filename but the incorrect drive letter.

                              It sounds like the registry file you are distributing is only configured for the default install paths? I also found the option within Beyond Compare after I'd fixed my registry already, so I don't know how well it works, but I hope that functionality will query the system for the correct install path and modify the registry correctly.

                              For those that still require the registry file for their fix, please notify them that they will need to edit it to match their install path if they haven't installed to the default directory.

                              All that said, I need to express how much I love Beyond Compare. I rarely (and I mean RARELY) experience any hiccups with it and use it 5-7 days/week. Thank you for this awesome utility!!!