No announcement yet.

Ignore First Line of xml lines

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ignore First Line of xml lines

    Problem Statement: We have a set of xml files which are auto-generated by system along with other files. The first line of xml file contains date of generation. So if nothing changes in the xml file, the first line still (with date) gets updated every time files are auto-generated, which is acceptable. But for the convenience of reviewers, I want to ignore the first line of all xml files.

    Version Details: BC4 Version 4.0.7 (build 19761)

    Solutions Tried:
    1. Tools -> File Formats -> XML -> Grammar. Added new item by name FirstLine. Selected bullet "Lines" and ticked "or Line 1". Saved and restarted BC4. But rule based comparison of XML files did not ignore first line.
    2. I tried few other solutions available on this forum as well. But none of them worked for me.

  • #2

    Solution 1 is close. You have to also update the Session Settings to uncheck the grammar element name, as elements can be Important (checked) or Unimportant (unchecked). This can be an updated session default to apply for all future comparisons, and also then run as a Rules-based scan on the Folder Compare to apply this scan to all files.

    All 4.x updates are free for 4.x users, if you were able to update to the latest 4.3.4:
    Aaron P Scooter Software