No announcement yet.

Folder Exclusions are ignored in “Ignore Folder Structure” mode

  • Time
  • Show
Clear All
new posts

  • Folder Exclusions are ignored in “Ignore Folder Structure” mode

    I am trying to fine-tune Beyond Compare file exclusion folders to eliminate large binary files that I do not want to check into a version control system such as git or subversion. I open a File Compare session with the folder in question and set it folder handling mode to “Ignore Folder Structure” so that I can sort by file size to locate the largest files. I can exclude extensions such as *.obj but when I try to exclude a folder such as .git or .svn the folder exclusions are ignored and the files I wish to exclude are still displayed. Is this a bug or an intentional feature? If it’s an intentional feature, how do I use Beyond compare to locate the largest files not meeting the exclusions I have set up?

  • #2

    There aren't any known issues like this. We'd probably need a screenshot showing what you are seeing, which you can post here or email to [email protected] along with a link back to this forum thread.

    One known limitation is the opposite: if you have filtered out a folder, which should work, and then enable Suppress Filters, the items will still not be shown. This is because the folder filters help lighten the load by excluding all of the subcontent. Otherwise, toggling on the view option could become extremely intensive as it then loads every file in potentially extremely large subfolders.

    Related, if you have two items that are aligned, if one is filtered out but the other is not, both will then be included with the excluded item in a teal coloring. This is intentional behavior since our side to side commands need to display what it might be overwriting if you tried to copy over. Otherwise, there would be scenarios where it looks like copying a file from side to side would appear to copy to an empty location but there's actually an item there, so we default to showing the item but in a different color to indicate the filter/excluded state.
    Aaron P Scooter Software


    • #3
      Here's a screenshot. Note that the .git folder is excluded but objects therein are listed despite the exclusion.

      Click image for larger version

Name:	image.png
Views:	68
Size:	152.7 KB
ID:	90178


      • #4
        The problem appears to be that ./.../<something> doesn't work in Ignore Folder Structure mode. If you change the exclusion to .git then the exclusion will work.
        .\...\<something> will also work. Using the forward slash works in all modes except "Ignore Folder Structure" mode.
        Last edited by japaget; 19-Apr-2023, 07:15 PM.


        • #5

          Thanks for the screenshot and your own troubleshooting. I've tried the same and that seems to be exactly it. In most cases, BC4 will transpose the slashes and allow you to use either, but something about that combined with Ignore Folder Structure isn't working. I suggest using the 'correct' Windows backslash\ for the filter (including the trailing\ which is mandatory for the filter string to designate a folder name in the toolbar) for now. I'll also open a tracker entry to investigate.
          Aaron P Scooter Software