No announcement yet.

BC3 suddenly (after many months) failing to start on Ubuntu

  • Filter
  • Time
  • Show
Clear All
new posts

  • BC3 suddenly (after many months) failing to start on Ubuntu

    I have been using BC3 for a couple years on the same Linux/Ubuntu VM and it's been fine. Recently, I am not sure when, bcompare hangs when executed at the command line with no visible output (command line or GUI):
    $ bcompare
    <hangs here>

    I tried apt-get remove and reinstall with gdebi (per the install instructions), but the symptoms remain the same.

    Any ideas? Some version info reported below.


    $ uname -a
    Linux exarajohn1 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
    Install package file name: bcompare-
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 14.04.3 LTS
    Release: 14.04
    Codename: trusty

  • #2

    Testing with my own Ubuntu 14.04 with 3.3.13, it appears to boot up and work with the latest updates applied.

    I would suggest reverting to factory default settings (which are not necessarily removed during an uninstall). They are in your /home/username/.config/bcompare/ directory and include BCState.xml, BCSessions.xml, etc. Move this folder or rename it, then start BC3 to recreate it.

    Assuming this works, you can then use the Tools menu -> Import to pick and Import specific settings from the old .xml files, and workaround whichever is currently set that is causing the hang. How does this work for you?
    Aaron P Scooter Software


    • #3

      Removing the files in the ~/.config/bcompare/ directory solved the problem. All I had to do was re-enter my license key and I was back in business. Thanks for the prompt support!