No announcement yet.

Core Dump on Arch Linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • Core Dump on Arch Linux

    I am on Antergos Linux (basically Arch) and recently BC4 started crashing during startup. I have always used this AUR without issue. When it stopped working, I downloaded the tgz directly from, unpacked it, and installed by following the instructions. I get the same symptoms with either install method. Both are installing version

    Whenever I try to run bcompare from the command line, there is about a 1-second pause, and then I get a core dump message:

    » bcompare
    /home/nalderso/bin/bcompare: line 43: 20371 Aborted                 (core dumped) /bin/bash -c "exec -a $0 $EXEC $ARGS > /dev/null 2>&1" $0
    Here's the core dump info:

    » coredumpctl info 20371
               PID: 20371 (BCompare)
               UID: 1000 (nalderso)
               GID: 100 (users)
            Signal: 6 (ABRT)
         Timestamp: Tue 2019-02-05 13:38:44 CST (38s ago)
      Command Line: /home/nalderso/bin/bcompare
        Executable: /home/nalderso/lib64/beyondcompare/BCompare
     Control Group: /user.slice/user-1000.slice/[email protected]/gnome-terminal-server.service
              Unit: [email protected]
         User Unit: gnome-terminal-server.service
             Slice: user-1000.slice
         Owner UID: 1000 (nalderso)
           Boot ID: [redacted]
        Machine ID: [redacted]
          Hostname: [redacted]
           Storage: /var/lib/systemd/coredump/core.BCompare.1000.[redacted]
           Message: Process 20371 (BCompare) of user 1000 dumped core.
                    Stack trace of thread 20371:
                    #0  0x00007fa9fb1dfd7f raise (
                    #1  0x00007fa9fb1ca672 abort (
                    #2  0x00007fa9fb222878 __libc_message (
                    #3  0x00007fa9fb22918a malloc_printerr (
                    #4  0x00007fa9fb22a98c _int_free (
                    #5  0x000000000044c34a n/a (/home/nalderso/lib64/beyondcompare/BCompare)
    My system is up to date and I tried a full reboot. Please let me know if I can provide more information.

  • #2
    Arch Linux and its derivatives aren't on the list of officially supported Linux distributions.

    Supported Linux Distributions:

    Unless we can duplicate the crash on a supported Linux distribution, we don't have the resources to spend a lot of time investigating crashes that only happen on unsupported Linux distributions.

    General troubleshooting steps like rebooting your computer and clearing your settings might be helpful. To reset your settings back to defaults, move the contents of ~/.config/bcompare/ to a backup folder. When you run Beyond Compare again, it should create new factory default settings.
    Chris K Scooter Software


    • #3
      I see. Rebooting and clearing settings have not helped.

      In case it is interesting to anyone...

      By editing the script to remove the output redirection on the line that actually executes the program, so line 44 becomes:

      /bin/bash -c "exec -a $0 $EXEC $ARGS" $0
      Then I get a bit more output when I run the script, which may helpful to someone troubleshooting:

      » ./
      Runtime error 216 at $00007F8A47AD8000
      free(): invalid size
      ./ line 44:  3749 Aborted                 (core dumped) /bin/bash -c "exec -a $0 $EXEC $ARGS" $0


      • #4
        I also posted the output of `strace bcompare` as a gist in case anyone wants to look.


        • #5
          I'm running Manjaro Linux (basically Arch) and bcompare is working fine for me.

          Comparing your "strace bcompare" with what I get, I don't see any of the locale things (line 197) in my output.