Announcement

Collapse
No announcement yet.

Crash when launching compare using command line

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Crash when launching compare using command line

    I just sent an email to support with these details, but thought I'd post here as well. I updated to 17036 a short while ago, but today I noticed that I cannot launch a compare from Cornerstone SVN on the Mac.

    I was able to launch a compare from Cornerstone prior to the update, but it's been a few weeks since I last tried. I cannot say for sure the crash is related to the recent BC4 build, but it seems likely.

    <BCCrash1386726856.txt> was attached to the email, and listed an Access Violation.


    I'm using the following AppleScript to launch the compare, but consistently receive a crash. Although I have an instance of BC4 open, it seems to launch another one, because I get the "Beyond Compare 30-day evaluation" popup each time. I'm not sure if that's normal or expected.

    Code:
    -- Cornerstone executes the script as:
    --	/path/to/tool <original> <modified>
    --
    on run argv
    	set originalFile to (item 1 of argv)
    	set modifiedFile to (item 2 of argv)
    	do shell script "/usr/local/bin/bcomp \"" & originalFile & "\" \"" & modifiedFile & "\""
    end run

  • #2
    Hello,

    I setup a trial of the latest version of Cornerstone SVN and set it to use this config file. It seems to boost and show the files without crashing.

    If you re-install the Command Line Tools (using the Beyond Compare menu -> Install Command Line Tools, does this help? If you alter the config to load only the originalFile or modifiedFile, is either side reponsible for the crash, and if so, could you alter the script to output to text that variable before passing it to BC4?
    Aaron P Scooter Software

    Comment


    • #3
      Well, this is embarrassing. It's apparently no longer crashing for me.

      After reading your reply, I immediately reinstalled the command line tools, which I'm pretty sure I had done when I started receiving the crashes and prior to submitting the report. I remember even looking to check the timestamp on the files at "/usr/local/bin".

      Anyhow, after launching Cornerstone, the compares run fine. I do see the "Your 30-day evaluation period has ended" message popup when each compare is requested. I don't think it did this before, so maybe I need a new evaluation key? I tried to use my original 4.0 beta key, but it says that it's expired. EDIT: BC4 is already open when I get these messages, not just when BC4 loads fresh.

      I'm not sure why I was receiving consistent crashes when launching compare from Cornerstone a couple days ago, but it appears to be working fine now. I have quit and relaunched both apps, but I don't believe I've reboot the system.

      Anyhow, thanks for looking into this!
      Last edited by mryan; 13-Dec-2013, 03:26 PM.

      Comment


      • #4
        Hello,

        The trial pop-up every time is an issue. It should only pop up once per day (the first time).

        If you try to launch from the taskbar, launching the GUI, does the same issue occur?
        Aaron P Scooter Software

        Comment


        • #5
          Each time I launch the app fresh, it shows the popup. If I quit the app and then open it immediately afterward, the popup reappears.

          With the command line tool, even when the app is already open, the popup appears each time the command line tool is executed.

          Comment


          • #6
            Are you within the original 30 day trial, or have you entered the grace period afterwards (where it still hasn't expired yet, but is warning you that it will soon)? If you are in the 2nd phase, then it would show the dialog each time.
            Aaron P Scooter Software

            Comment

            Working...
            X