Announcement

Collapse
No announcement yet.

Start BC4 without restoring session

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Start BC4 without restoring session

    I use BC4 a lot to compare files on NFS auto-mounted filesystems. At times, the filesystems are not mounted, at which point I cannot startup BC4; it just hangs and the Dock icon bounces until I kill it. Is there a way to force BC4 to start without reloading the session (I like the session reload capability, so I'd prefer not to turn it off unless I have to). Thanks!

    OSX: 11.6.1
    BC4: 4.4 (build 25886)
    Last edited by JoeCasadonte; 07-Dec-2021, 08:19 AM. Reason: (added BC4 version after reboot and reconnect to VPN)

  • #2
    Hello,

    Could you double check how long the hang occurs for? Sometimes a network timeout can be quite long (multiple minutes) and there are scenarios where we're stuck waiting for the remote resource to respond. If you let it sit for a really long time (5+ minutes) does it eventually recover or is it a complete hang? Neither is ideal; I'd just like to narrow down the scenario.
    Aaron P Scooter Software

    Comment


    • #3
      I did see one time where the Dock icon stopped bouncing, but I don't know how long it took and the end result was that the program just failed to open. Every other time I have forced quit it before that point. And of course today I cleared my session history because I didn't want to deal with the issue, so it started up just fine even though I'm not VPN'd in to work (which is where the NFS-mounted drives are).

      I think it's not unreasonable for the hang, and it's probably happening at the OS-level because of the NFS automount. I'm just hoping that there's a way to avoid it with a command-line switch or something.

      Comment


      • #4
        Hello,

        Would it be possible to get more information on how you are launching BC4? By session reload, are you using the Launch Workspace on Startup option, pointing to the the auto-saved Save Workspace on close workspace?

        And what is the exact syntax/example of file paths that throw this issue? I've set up a couple similar scenarios, but after disconnecting the VPN, the remote resource is detected as not found within a few seconds, and throws up a standard location/file not found error. If you'd like to email privately, you can email us at [email protected] including a link back to this forum thread for our reference. It's also ok to obfuscate the exact text, but knowing the protocol and syntax is important.
        Aaron P Scooter Software

        Comment


        • #5
          Hi Aaron,

          I almost always launch BC4 by clicking on the pinned Dock icon, but occasionally via git difftool.

          Here are the BC4 options that may be relevant; let me know if there are any others you’d like to see:
          • Startup
            • Load workspace: empty
            • On exit, save workspace as: empty
          • Backups
            • nothing selected
          • Tweaks
            • File Operations – Check for files changed on disk: selected
            • Shared Sessions File – empty

          I had deleted all of my sessions, so in the session panel on the left of the main screen there was nothing except for the “New” section – see attached.

          A correction from previously reported information: this is a straight-up NFS mount, not an automount. The command used to mount is:

          sudo mount -t nfs -o nolock,resvport HOSTNAME:/remote/path/name /System/Volumes/Data/Users/USERNAME/some/path

          Then I have a symlink in a local path (e.g. /opt/foo) that points to the /System/Volumes/... path, e.g.

          <~> $ ll /opt/foo
          lrwxr-xr-x 1 root wheel 41 Jun 23 2020 /opt/foo -> /System/Volumes/Data/Users/USERNAME/some/path


          This is both simpler to reproduce than I thought and consequently much more confusing for me to understand. I was going to try to be meticulous in my instructions to reproduce it, making one change at a time and then testing, but I didn’t expect it to fail on my very first iteration through, so some things I was not 100% certain of because I didn’t yet think they would be relevant...

          I had been using BC4 since a reboot a couple of days ago, both while I was VPN’d in and not VPN’d in, but I had not yet mounted the NFS volume. As a first test, almost a control, really, I mounted the NFS volume, then dropped off of VPN, then tried to open BC4; it hung, which was unexpected because I wasn’t sure how BC4 even knew about it at this point (I’m very nearly certain that BC4 was not open when I mounted the NFS volume, but I’m not 100% sure). BC4 hung for 2-3 minutes with a bouncing Dock icon before it finally stopped, but I still had to Force Quit it even after it stopped bouncing. I reconnected to VPN and made sure that the OS had seen that the mount was now available (typing ls -l /opt/foo in a Terminal window and waiting for it to complete, about 10-15 seconds) and then tried BC4 and it started up immediately.

          I dropped off of VPN and tried BC4 and it started. I could not get BC4 to hang under any circumstance until I unmounted the NFS share, started BC4 & quit it, then re-mounted the NFS share and dropped off of the VPN. Then when I started BC4 it hung.

          This all combined leads me to believe it’s not something to do with sessions, since I have none, and might just be a simple mounted file systems scan of some sort. Maybe even just a filesystem it hasn’t seen “recently”? Let me know what else you’d like me to try. If it helps to run some kind of debug build I can do that, and if it helps to jump on a screen sharing session to poke and prod in real time, I can do that, too.
          Last edited by JoeCasadonte; 10-Dec-2021, 10:21 AM.

          Comment

          Working...
          X